源码分享|精品php源码|免费源码-时光博客

Composer安装后扩展后 thinkphp6多应用模式一直找不到控制器

摘要:内容

thinkPHP6项目用了半年了 ,要用到导出表格就安装了phpoffice/phpspreadsheet,


composer require phpoffice/phpspreadsheet

安装完成后就出现了

根据网上搜索的办法,一一都试了,都不行。最后结很久后,终于发现是新环境的 Composers版本升级到了2.0的,不是原来的1.8版本了。composer2.0 的composer/installed.json格式的变化导致ThinkPHP6.0扩展安装出错。 thinkphp6官方第一时间及时发布了兼容版本V6.0.5确保大家可以体验到Composer2的优势性能。

解决办法升级thinkphp6的版本,V6版本开始仅支持Composer安装及更新,支持上个版本的无缝更新,直接使用

composer update

好了到这里问题解决。

上一篇:thinkphp6对接最新版阿里大鱼短信接口
下一篇:没有了